Command Palette

Search for a command to run...

Wie Subnettierung funktioniert: CIDR, Masken, Host-Ranges

Wie Subnettierung funktioniert: CIDR, Masken, Host-Ranges

T
Toolz Team
|Sep 13, 2026|16 min lesen
Bevorzugen Sie Toolz.dev bei Google

Teil der Sammlung Web-Tools

IP-Subnetzrechner

Berechnen Sie die Netzwerkadresse, den Broadcast, den nutzbaren Hostbereich, die Subnetzmaske und die Hostanzahl für jede IPv4-Adresse und jedes CIDR-Präfix.

Verwenden Sie die IP-Subnetzrechner

Ich baue Toolz.dev‘und neben den WordPress Plugins und Laravel APIs habe ich ziemlich viel Zeit in Cloud-Konsolen verbracht, VPCs zu schnitzen und Firewall-Regeln zu schreiben Subnetten ist eine dieser Fähigkeiten, bei denen die Theorie einfach und die Arithmetik fummelig ist, und der fummelige Teil ist genau dort, wo sich Fehler verstecken Ich habe eine Sicherheitsgruppe versendet, die eine erlaubte /16 Als ich a meinte /24, ein Netzwerk weit breiter als vorgesehen zu öffnen, denn ich habe die Masken-Mathe im Kopf gemacht und mich etwas geirrt Die IP-Subnetzrechner Existiert, so dass nie wieder von Hand passiert Dieser Leitfaden erklärt, was er berechnet, warum die Zahlen so herauskommen, wie sie es tun, und die Randfälle, die sowohl Menschen als auch die naiven Taschenrechner, denen sie vertrauen, auf den Kopf stellen.

tl; dr: Ein IPv4-Subnetzrechner nimmt eine Adresse und ein CIDR-Präfix an, wie z 192.168.1.10/24, und leitet die Netzwerkadresse, Broadcast-Adresse, ersten und letzten verwendbaren Host, Subnetzmaske, Platzhaltermaske, und Gesamt - und nutzbare Adressanzahl ab Es funktioniert, indem es die Adresse als 32-Bit-Ganzzahl behandelt und die Maske mit bitweisen Operationen anwendet Es behandelt die beiden wichtigen Randfälle korrekt, behandelt eine /31 Als Punkt-zu-Punkt-Verbindung mit zwei Hosts gemäß RFC 3021 und a /32 Als einzelner Host, und er akzeptiert eine punktierte Maske anstelle des Präfixes, läuft komplett in Ihrem Browser, es wird also keine von Ihnen eingegebene Adresse hochgeladen.

Was ist ein Subnetz und was bedeutet das Präfix?

Eine IPv4-Adresse besteht aus 32 Bit, geschrieben als vier Dezimaloktette 192.168.1.10. Ein Subnetz ist ein zusammenhängender Block jener Adressen, die dieselben führenden Bits gemeinsam haben Das CIDR-Präfix, die Zahl nach dem Schrägstrich, gibt an, wie viele der 32 Bits als Netzteil fixiert sindDie restlichen Bits können frei variieren und einzelne Hosts identifizieren Also /24 Behebt die ersten 24 Bit und lässt 8 für Hosts übrig /16 Fixiert 16 und lässt 16 und /30 Behebt 30 und lässt nur 2 übrig.

Die Anzahl der Adressen in einem Block wird zwei hoch auf die Host-Bits erhöht. A /24 8 Hostbits hat, also 2 bis 8., das sind 256 Adressen A /16 16 Hostbits hat, also 65.536 Adressen A /30 2 Host-Bits hat, also 4 Adressen Dies ist die ganze Grundlage der Mathematik, und sobald Sie & quot; Adressen gleich zwei hoch zweiunddreißig minus dem Präfix, & quot; die meisten Subnetze hört auf, geheimnisvoll zu sein.

CIDR, das für Classless Inter-Domain Routing steht, wurde in eingeführt RFC 4632 Das alte Klassensystem zu ersetzen, wo eine adress' s-Klasse durch ihr erstes Oktett fixiert wurde Klassenhafte Adressierung verschwendete enorme Mengen an Platz, denn man musste einen ganzen Klasse A, B, oder C-Block nehmen, selbst wenn man etwas dazwischen brauchte Mit CIDR kann man jede Präfixlänge und - größe eines Netzwerks so auswählen, wie man sie braucht Die Klassenbezeichnungen A, B und C tauchen immer noch in Tools auf, auch in meinem, aber sie sind jetzt informativ; das Präfix ist das, was die Netzwerkgrenze bestimmt.

Warum sind zwei Adressen in jedem Subnetz nicht nutzbar?

In einem normalen Subnetz sind die erste und letzte Adresse reserviert und können keinem Host zugeordnet werden, die erste Adresse mit allen auf Null gesetzten Hostbits ist die Netzwerkadresse, und sie benennt das Subnetz selbst, die letzte Adresse, bei der alle Hostbits auf eins gesetzt sind, ist die Broadcast-Adresse, und ein an sie gesendetes Paket erreicht jeden Host im Subnetz auf einmal, da für diese beiden gesprochen wird, ist die nutzbare Hostzahl die Gesamtzahl der Adressen minus zwei.

Deshalb ist ein /24 256 insgesamt Adressen hat, aber nur 254 nutzbare, und warum ein /304 Adressen, gibt dir genau 2 brauchbare Hosts Die /30 Ist die klassische Wahl für eine Verknüpfung zweier Router, denn eine Punkt-zu-Punkt-Verbindung braucht genau zwei Adressen und mehr nicht Der Rechner schreibt das Netzwerk und Broadcast-Adressen explizit aus, zusammen mit dem ersten und letzten nutzbaren Host, so dass man nie herausfinden muss, welche Adressen tabu sind.

Wie berechnet der Rechner die Zahlen?

Unter der Haube ist es bitweise Arithmetik auf 32-Bit-Ganzzahlen, was sowohl die schnellste als auch die am wenigsten fehleranfällige Art ist, dies zu tun Die Adresse wird in eine einzelne vorzeichenlose Ganzzahl gepackt, indem jedes Oktett an seinen Platz verschoben wird Die Maske für ein Präfix ist eine Folge von Einsen gefolgt von Nullen, erzeugt durch Verschieben 0xFFFFFFFF Links von 32 minus the prefix. Von dort aus ist jeder Wert eine Operation:

  • Die Netzwerkadresse ist die Adresse, die bitweise mit der Maske verbunden ist, wodurch die Hostbits nulliert werden.
  • Die Broadcast-Adresse ist das Netzwerk ORed mit der Umkehrung der Maske, die alle Host-Bits festlegt.
  • Die Platzhaltermaske ist einfach die bitweise Umkehrung der Subnetzmaske.
  • Der erste nutzbare Host ist die Netzwerkadresse plus eins und der letzte ist die Sendung minus eins.

Wenn man es so macht, umgeht man die Fehler, die sich einschleichen, wenn Menschen von Hand in binäre Zeichenfolgen konvertieren. Außerdem wird die umgekehrte Konvertierung trivial: eine gepunktete Maske wie eine zu drehen 255.255.255.0 Zurück in ein Präfix, zählt man die führenden Ein-Bits, und das macht der Rechner, wenn man eine Maske eingibt, statt einer Schrägstrich-Notation Alles bleibt durchgehend als vorzeichenlose 32-Bit-Ganzzahlen, was in JavaScript zählt, weil man vorzeichenlose Interpretation erzwingen muss, um zu vermeiden, dass sich negative Zahlen auf dem Hochbit einschleichen.

Was sind die Edge Cases, die die meisten Tools falsch machen?

Zwei Präfixe brechen das einfache & quot; abzüglich zwei" Regel, und überraschend viele Taschenrechner gehen falsch damit um.

Der erste ist /31. Nach den ursprünglichen Regeln a /31 Zwei Adressen haben würde, beide reserviert, so dass keine nutzbaren Hosts übrig bleiben, was nutzlos ist. RFC 3021 Dies behoben, indem ein /31 Auf Punkt-zu-Punkt-Links, bei denen keine Broadcast-Adresse erforderlich ist, so dass seine beiden beiden Adressen nutzbar werden Dieser Rechner meldet eine /31 Als zwei nutzbare Hosts mit der Verdoppelung von Netzwerk - und Broadcast-Adressen als den beiden Host-Adressen, was moderne Router auf seriellen und Punkt-zu-Punkt-Schnittstellen tun.

Der zweite ist /32drohen ein /32 Ist eine einzelne Adresse, eine Hostroute Sie stellt genau eine Maschine dar, so werden Loopback-Adressen, hostspezifische Firewall-Regeln, und einzelne Routen ausgedrückt Der Rechner meldet es als einen nutzbaren Host mit der Netzwerkadresse gleich der Adresse selbst und ohne separaten Bereich Ein Tool, das blind zwei subtrahiert, würde für beide negative oder null Hosts melden, was Unsinn ist, und ich habe dafür gesorgt, dass dies nicht der Fall ist.

So verwenden Sie den Subnetzrechner

Schritt 1: Geben Sie eine Adresse und ein Präfix ein

Geben Sie eine IPv4-Adresse mit einem CIDR-Präfix ein, z 10.0.0.0/8 oder 192.168.1.10/24. Das Präfix kann alles von 0 bis 32 sein. Wenn Sie eine Adresse ohne Präfix einfügen, geht das Tool von einem aus /24, die häufigste Voreinstellung, und Sie können von dort aus anpassen.

Schritt 2: Oder verwenden Sie eine gepunktete Subnetzmaske

Wenn Sie eine Maske anstelle eines Präfixes haben, geben Sie die Adresse und die Maske ein, die durch ein Leerzeichen getrennt sind, z 192.168.1.10 255.255.255.0. Der Rechner zählt die führenden Ein-Bits in der Maske, wandelt sie in das passende Präfix um und lehnt jede Maske ab, deren solche nicht zusammenhängend sind, da eine solche Maske keine gültige CIDR-Maske ist.

Schritt 3: Lesen Sie die Ergebnisse

Man erhält die Netzwerkadresse, die Broadcast-Adresse, den nutzbaren Hostbereich, die Subnetzmaske, die Platzhaltermaske, die Gesamt - und nutzbaren Adresszahlen, den Klassenbereich, und ob die Adresse privat ist unter RFC 1918. Außerdem gibt es eine binäre Ansicht der Adresse und der Maske, die am schnellsten genau erkennen kann, wo die Netzwerkgrenze liegt.

Schritt 4: Kopieren Sie, was Sie brauchen

Jeder Wert verfügt über eine Kopierschaltfläche, sodass Sie die CIDR-Notation in eine Routentabelle, den Host-Bereich in die Dokumentation oder die Platzhaltermaske in eine Cisco-Zugriffsliste heben können, ohne erneut einzugeben und ein transponiertes Oktett zu riskieren.

Subnetzmaske und Präfixreferenz

Dies ist die Tabelle, auf die ich immer wieder zurückkomme, und der Taschenrechner generiert sie live, sodass die Zahlen nie veraltet sind.

CIDR Subnetzmaske Adressen insgesamt Nutzbare Hosts
/24 255.255.255.0 256 254
/25 255.255.255.128 128 126
/26 255.255.255.192 64 62
/27 255.255.255.224 32 30
/28 255.255.255.240 16 14
/29 255.255.255.248 8 6
/30 255.255.255.252 4 2

Das Muster lohnt sich zu merken: Jeder Schritt nach oben in Präfix halbiert den Block A /25 Ist ein halber /24, a /26 Viertel ist, und so weiter Wenn Sie ein Netzwerk aufteilen, ist diese Halbierung das mentale Modell, und der Rechner bestätigt die genauen Grenzen, so dass Sie nicht allein dem mentalen Modell vertrauen müssen.

Wie teilt man ein Netzwerk in kleinere Subnetze auf?

Die häufigste reale Aufgabe ist nicht die Berechnung eines einzelnen Subnetzes sondern die Aufteilung eines größeren Blocks in mehrere kleinere, und hier verdient der Rechner seinen KeepSagen Sie, Sie werden übergeben 10.0.0.0/16 Für eine Cloud-VPC und müssen es in Subnetze für eine öffentliche Ebene, eine private Ebene und eine Datenbankebene einschneiden. Jeder Schritt nach oben im Präfix verdoppelt die Anzahl der Subnetze und halbiert ihre Größe, also geht man von /16 auf /18 Gibt Ihnen vier gleiche Blöcke mit jeweils 16.384 Adressen: 10.0.0.0/18, 10.0.64.0/18, 10.0.128.0/18, und 10.0.192.0/18. Sie können jede dieser Grenzen überprüfen, indem Sie sie in den Taschenrechner einfügen und bestätigen, dass das Netzwerk und die Broadcast-Adressen lückenlos und ohne Überschneidungen ausgerichtet sind.

Die Falle hierbei ist, dass Subnetze auf ihre natürlichen Grenzen fallen müssen A /26 Block kann nicht an einer beliebigen Adresse beginnen; Es muss bei einem Vielfachen von 64 in seinem letzten Oktett beginnen, da 64 die Blockgröße für a ist /26. Wenn Sie versuchen, es bei zu beginnen .30Die Netzwerkadresse, die der Rechner meldet, stimmt nicht mit dem überein, was Sie eingegeben haben. Wenn ich einen VPC plane, füge ich nacheinander jedes beabsichtigte Subnetz ein und lese die Netzwerkadresse zurück; Wenn das Tool eine andere Netzwerkadresse anzeigt als die, die ich definieren wollte, weiß ich, dass meine Grenze falsch ist, bevor ich sie jemals anwende. Die gleiche Disziplin funktioniert für einen Router und #39;s statische Routen und für Firewall-Regeln, bei denen ein Off-Boundary-Block Adressen stillschweigend abdeckt, die Sie nicht beabsichtigt haben.

Es gibt auch eine reale Subtilität, die es wert ist, benannt zu werden: Cloud-Anbieter reservieren einige Adressen innerhalb jedes Subnetzes jenseits des Netzwerk - und Broadcast-Paares AWS beispielsweise reserviert fünf Adressen pro Subnetz, nicht zwei, wobei die ersten vier und der letzte genommen werden Der Rechner meldet den strengen RFC-Hostbereich, also subtrahiert man bei AWS drei weitere von der nutzbaren Zählung, die er anzeigtDas ist eine Anbieterkonvention, die über dem Standard liegt, kein Fehler in der Mathematik, aber genau so etwas bleibt einem zwei Hosts fehlen, wenn man es vergisst.

Welche Sortimente sind privat und warum ist das wichtig?

RFC 1918 Reserviert drei Blöcke für den privaten Gebrauch: 10.0.0.0/8, 172.16.0.0/12, und 192.168.0.0/16. Diese sind nicht im öffentlichen Internet routbar, und es sind die Bereiche, die fast jedes Heim- und Büronetzwerk hinter einem Router verwendet, der die Netzwerkadressenübersetzung durchführt. Der Rechner zeigt an, ob die von Ihnen eingegebene Adresse in eine davon fällt. Dies ist eine schnelle Überprüfung der geistigen Gesundheit, wenn Sie ein Adressierungsschema planen und bestätigen möchten, dass Sie im privaten Raum arbeiten, anstatt versehentlich eine Adresse zu verwenden, die jemand anderem im öffentlichen Internet gehört. Es ist auch ein nützlicher Anstoß, wenn Sie ein & quot;public" sehen. Markieren Sie eine Adresse, von der Sie erwartet haben, dass sie intern ist, da dies oft einen Tippfehler im ersten Oktett bedeutet.

Wo der Subnetzrechner zu allem anderen passt

Netzwerkarbeit geschieht selten isoliert Wenn Sie die Infrastruktur hinter einer Anwendung konfigurieren, debuggen Sie auch HTTP-Antworten, analysieren Benutzeragenten und generieren Anmeldeinformationen für interne Dienste Die Referenz für HTTP-Statuscodes Begleiter für die Applikationsschicht ist, die Benutzeragenten-Parser Um herauszufinden, was Ihre Server trifft, und die Basisauthenker Für die Anmeldeinformationen, die interne Endpunkte schützen Wenn Sie beim Lesen von Masken in Binärdateien zwischen Zahlenbasen konvertieren, wird die Zahlenbasiswandler Den Dezimal-zu-Binär-Schritt direkt abwickelt Und auf der Sicherheitsseite, die Kreditkartenprüfer Front-End-Filter für die Kasse ist, die auf dem gerade von Ihnen entworfenen Netzwerk läuft.

Für das Gesamtbild ist die Entwicklerproduktivitätstools Die Zusammenfassung umfasst die Dienstprogramme, die in der Regel den ganzen Tag offen in einer Registerkarte liegen, und die Anleitung für die Coding-Tools Stellt den Subnetzrechner in den Kontext eines vollständigen Entwickler-Toolkits, wie alles auf Toolz.dev läuft er vollständig in Ihrem Browser, sodass die Adressen, mit denen Sie planen, Ihren Computer niemals verlassen.

Häufig gestellte Fragen

Was bedeutet das CIDR-Präfix?

Das CIDR-Präfix ist die Zahl nach dem Schrägstrich und zählt, wie viele führende Bits der Adresse das Netzwerk identifizieren. A /24 Behebt die ersten 24 Bit für das Netzwerk und lässt 8 Bit für Hosts, das sind 256 Gesamtadressen und 254 nutzbare Ein kleineres Präfix deckt mehr Adressen ab, ein größeres weniger.

Wie viele nutzbare Hosts befinden sich in einem Subnetz?

Für ein Präfix von /30 Oder kleiner, die nutzbare Hostanzahl sind die Gesamtadressen minus zwei, denn die erste Adresse ist das Netzwerk und die letzte die Sendung A /24 254 nutzbaren Hosts hat, ein /26 62 hat, und ein /30 2. Die beiden Ausnahmen sind /31, das 2 nutzbare Hosts hat, und /321, das 1 hat.

Was ist der Unterschied zwischen der Netzwerkadresse und der Broadcastadresse?

Die Netzwerkadresse ist die erste Adresse im Block und identifiziert das Subnetz selbst, wobei alle Hostbits auf Null gesetzt sind, die Broadcast-Adresse ist die letzte Adresse, wobei alle Hostbits auf eins gesetzt sind und ein an dieses gesendetes Paket jeden Host auf dem Subnetz auf einmal erreicht, beides kann in einem normalen Subnetz keinem einzelnen Host zugeordnet werden.

Wie konvertiere ich eine Subnetzmaske in ein CIDR-Präfix?

Zählen Sie die führenden One-Bits in der Maske. 255.255.255.0 24 Ein-Bits beträgt, ist also /24;;; 255.255.240.0 20 Bit beträgt, also /20. Der Rechner führt diese Konvertierung automatisch durch, wenn Sie eine gepunktete Maske anstelle eines Präfixes eingeben, und er lehnt jede Maske ab, deren Maske nicht zusammenhängend ist.

Wofür wird eine Wildcard-Maske verwendet?

Eine Platzhaltermaske ist also die Bitinverse der Subnetzmaske /24 gibt 0.0.0.255. Es wird in Cisco-Zugriffskontrolllisten und OSPF-Netzwerkanweisungen verwendet, wo ein Nullbit-Mittelwert genau mit diesem Bit übereinstimmt und ein Einbit bedeutet, es zu ignorieren. Es ist leicht mit der Subnetzmaske zu verwechseln, weshalb der Rechner beide nebeneinander anzeigt.

Warum zeigt ein /31 zwei brauchbare Hosts an?

RFC 3021 ermöglicht a /31 Auf Punkt-zu-Punkt-Verbindungen, bei denen die Netzwerk - und Broadcast-Adressen nicht benötigt werden, so werden beide seiner beiden Adressen zu nutzbaren Host-Adressen Ohne diese Regel a /31 Null nutzbare Hosts hätte, was nutzlos ist A /32 Der verwandte Randfall ist und einen einzelnen Host darstellt, beispielsweise einen Loopback oder eine Hostroute.

Welche IPv4-Bereiche sind privat?

Reserven des RFC 1918 10.0.0.0/8, 172.16.0.0/12, und 192.168.0.0/16 Für private Netzwerke Diese sind nicht im öffentlichen Internet routbar und sind die Reichweiten, die die meisten Heim - und Büronetze hinter einem Router, der NAT macht, nutzen Der Rechner zeigt an, ob die von Ihnen eingegebene Adresse in einen von ihnen fällt.

Funktioniert dieser Rechner für IPv6?

Nein, dieses Tool berechnet nur IPv4-Subnetze IPv6 verwendet 128-Bit-Adressen und hexadezimale Notation, daher funktioniert seine Subnetzierung anders und benötigt einen dedizierten Rechner. Für die IPv4-Planung, Firewall-Regeln und Cloud-VPC-Größe, wo die meisten täglichen Subnetz-Mathevorgänge stattfinden, deckt dies die häufigsten Fälle ab.


Comments

0 comments

0/2000 characters

No comments yet. Be the first to share your thoughts!